Difference between revisions of "Common Linux Libraries That Wine Might Need"

From PlayOnLinux
Jump to: navigation, search
(Games and softwares between 1995 - 2005)
(Games and softwares before 2010)
 
(2 intermediate revisions by the same user not shown)
Line 6: Line 6:
 
== Games and softwares between 2005 - 2020 ==
 
== Games and softwares between 2005 - 2020 ==
 
A lot of these games/softwares need a [https://en.wikipedia.org/wiki/.NET_Framework Microsoft DotNet framework]. The next problem is to know which version (usually: the newer the better).
 
A lot of these games/softwares need a [https://en.wikipedia.org/wiki/.NET_Framework Microsoft DotNet framework]. The next problem is to know which version (usually: the newer the better).
 +
 +
== Games and softwares before 2010 ==
 +
To make audio/music work, this piece of code may be required in the .POL installation script:
 +
 +
  ## Sound problem fix - pulseaudio related
 +
  [ "$POL_OS" = "Linux" ] && Set_SoundDriver "alsa"
 +
  [ "$POL_OS" = "Linux" ] && Set_SoundEmulDriver "Y"
 +
  ## End Fix
  
 
== What components does a Windows software use ? ==
 
== What components does a Windows software use ? ==
 
A way to know it is to submit the main .EXE file of the software to this meta-search engine : www.virustotal.com
 
A way to know it is to submit the main .EXE file of the software to this meta-search engine : www.virustotal.com
 
then click the tab 'Details', then look under the line 'Imports'.
 
then click the tab 'Details', then look under the line 'Imports'.

Latest revision as of 23:36, 6 November 2019

Write me !

Games and softwares between 1995 - 2005

A lot of these games/softwares need the file MFC42.DLL (Microsoft Foundation Class Library, it is a component of Microsoft Visual C). POL feature : POL_Install_mfc42

Games and softwares between 2005 - 2020

A lot of these games/softwares need a Microsoft DotNet framework. The next problem is to know which version (usually: the newer the better).

Games and softwares before 2010

To make audio/music work, this piece of code may be required in the .POL installation script:

 ## Sound problem fix - pulseaudio related
 [ "$POL_OS" = "Linux" ] && Set_SoundDriver "alsa"
 [ "$POL_OS" = "Linux" ] && Set_SoundEmulDriver "Y"
 ## End Fix

What components does a Windows software use ?

A way to know it is to submit the main .EXE file of the software to this meta-search engine : www.virustotal.com then click the tab 'Details', then look under the line 'Imports'.